[Thread Prev][Thread Next][Thread Index]

Re: cannot interpret PilotManager

> PilotManager requires perl version 5.002 but I only have (so far) the 5.001
> version.
> When I try to run PilotManager (after uncompressing
> pilotmgr_v1.008.sun4-solaris.tar.gz) I got the following error message:
> Can't use subscript on ref-to-glob cast at
> /proj/ur/usr/yvan/pilotmgr/lib/Data/Dumper.pm line 368, near "$k}"
> BEGIN failed--compilation aborted at
> /proj/ur/usr/yvan/pilotmgr/PilotMgr/Pilot.pm line 3.
> BEGIN failed--compilation aborted at PilotManager line 95.
> Any idea what I can do (appart from upgrading perl ;-)? 
> It is time for me to learn some perl, I guess!

The module that's crashing is the third-party Dumper module.
I didn't write it, nor does it make sense for me to seriously
try to debug it.

I'd suggest upgrading to Perl 5.003 if at all possible.  The
upgrade process is fairly easy, it's much more stable, and you'll
get to use PilotManager.  :-)

*      This is a public mailing list!      *
*  Please do not publish Sun proprietary   *
*            information here!             *

SourceForge.net Logo